"Nitro Cloud Outage" General service failure
Incident Report for Nitro Cloud Platform
Resolved
The issue has now been resolved. All systems are operational.
Posted 3 months ago. Feb 10, 2018 - 22:17 UTC
Investigating
We are currently investigating this issue.
Posted 3 months ago. Feb 10, 2018 - 20:05 UTC