Nitro Cloud login issues
Incident Report for Nitro Cloud Platform
Resolved
We identified the issue as a problem at our hosting vendor. The issue has been resolved and all operations are now functional.
Posted almost 2 years ago. Jun 27, 2016 - 15:55 UTC
Investigating
We've identified an issue with users trying to login to Nitro Cloud. We are still working on determining cause and will provide an update shortly.
Posted almost 2 years ago. Jun 27, 2016 - 15:28 UTC