Documents not loading in Nitro Sign
Incident Report for Nitro Sign
Resolved
The investigation is complete and service is fully available.
Posted Oct 27, 2020 - 14:45 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Oct 27, 2020 - 14:24 UTC
Investigating
We are running an upgrade to our database that may temporarily result in documents not loading in Nitro Sign.
Posted Oct 27, 2020 - 14:11 UTC
This incident affected: Nitro Sign Document Processing.