Unable to "Share" or "Request Signature" on documents through Nitro Pro
Incident Report for Nitro Cloud Status
Resolved
This incident is now resolved.
Posted Mar 11, 2020 - 22:15 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Mar 11, 2020 - 22:13 UTC
Identified
The root cause of the issue has been identified and the team is working on a fix
Posted Mar 11, 2020 - 22:02 UTC
Investigating
We are seeing issues with trying to 'Share' and 'Request Signature' on documents in Nitro Pro (v13) which we are currently working to rectify.
Posted Mar 11, 2020 - 21:42 UTC
This incident affected: Cloud Login.