Nitro Cloud Temporarily Unavailable
Incident Report for Nitro Sign Status
Resolved
Service has been restored and all affected services are back up and running. We will continue to monitor closely.
Posted Mar 28, 2019 - 16:08 UTC
Identified
We believe we have identified the root cause and are acting to remediate.
Posted Mar 28, 2019 - 15:41 UTC
Investigating
We are seeing an elevated number of errors while performing some routine infrastructure upgrades which is affecting the availability of Nitro Cloud. We are actively investigating.
Posted Mar 28, 2019 - 15:33 UTC
This incident affected: Nitro Sign Login, Nitro Sign Document Processing, Account Portal, and Document Upload.