Issue with Nitro Sign/Nitro Admin login

Incident Report for Nitro Sign

Resolved

The investigation is complete and service is fully available.
Posted Jan 22, 2021 - 06:39 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jan 22, 2021 - 06:38 PST

Update

We are continuing to investigate this issue.
Posted Jan 22, 2021 - 06:25 PST

Investigating

We are investigating a possible service disruption with Nitro Sign. Stay tuned for further updates.
Posted Jan 22, 2021 - 06:15 PST
This incident affected: Nitro Sign Login.