Nitro Cloud: Sporadic Failures Uploading Documents
Incident Report for Nitro Cloud Platform
Resolved
The issues we were seeing with our storage provider have now been resolved and service is back to normal.
Posted about 1 year ago. Jul 03, 2017 - 14:35 UTC
Investigating
We are investigating a number of failures uploading documents to Cloud due to connectivity issues between our services and our storage provider.
Posted about 1 year ago. Jul 03, 2017 - 13:42 UTC