Investigating Issue
Incident Report for Nitro Sign
Resolved
The investigation is complete and service is fully available.
Posted Nov 08, 2022 - 15:37 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 08, 2022 - 15:10 UTC
Update
We are continuing to investigate this issue.
Posted Nov 08, 2022 - 15:07 UTC
Investigating
We are investigating a possible service disruption with Nitro Sign. Stay tuned for further updates.
Posted Nov 08, 2022 - 14:49 UTC
This incident affected: Nitro Sign Document Processing and Document Upload.