Issue with accessing Nitro Sign

Incident Report for Nitro Sign

Resolved

This incident has been resolved.
Posted Aug 11, 2020 - 02:22 PDT

Monitoring

Service has been restored and all affected services are back up and running. We will continue to monitor closely.
Posted Aug 11, 2020 - 02:00 PDT

Identified

A fix for the issue has been identified and is being put in place.
Posted Aug 11, 2020 - 01:42 PDT

Investigating

We are currently investigating this issue
Posted Aug 11, 2020 - 01:14 PDT
This incident affected: Nitro Sign Login.