Issues with login on Nitro Sign & Nitro Admin
Incident Report for Nitro Sign
Resolved
The investigation is complete and service is fully available.
Posted Feb 10, 2021 - 13:35 UTC
Update
We are continuing to investigate this issue
Posted Feb 10, 2021 - 13:23 UTC
Investigating
We are investigating a possible service disruption with Nitro Sign. Stay tuned for further updates.
Posted Feb 10, 2021 - 13:12 UTC
This incident affected: Nitro Sign Login.