Issues with processing documents in Nitro Sign
Incident Report for Nitro Sign Status
Resolved
This incident has been resolved.
Posted Jun 08, 2020 - 10:12 UTC
Monitoring
A fix has been added and we are monitoring the results.
Posted Jun 08, 2020 - 09:30 UTC
Identified
The issue has been identified and a fix is being added
Posted Jun 08, 2020 - 09:28 UTC
Investigating
We are seeing issues with processing documents in Nitro Sign, which is affecting uploading documents, sending documents for signature and using Templates. We are currently investigating this issue.
Posted Jun 08, 2020 - 09:25 UTC
This incident affected: Nitro Sign Document Processing.