Investigating Issue
Incident Report for Nitro Sign
Resolved
The investigation is complete and service is fully available.
Posted Nov 07, 2022 - 03:09 UTC
Update
We are continuing to monitor for any further issues.
Posted Nov 07, 2022 - 02:07 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 07, 2022 - 02:05 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 07, 2022 - 01:52 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 07, 2022 - 01:51 UTC
Update
We are experiencing an issue with document upload. Document upload will appear to time out but the upload will succeed.

The issue has been identified and we are awaiting a fix.
Posted Nov 07, 2022 - 01:44 UTC
Update
We are continuing to work on a fix for this issue.
Posted Nov 07, 2022 - 01:40 UTC
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 07, 2022 - 01:32 UTC
Investigating
We are investigating a possible service disruption with Nitro Sign. Stay tuned for further updates.
Posted Nov 07, 2022 - 00:13 UTC
This incident affected: Nitro Sign Document Processing, Nitro Sign Notification Delivery, and Document Upload.